Commit c30b9a47 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

Require ALSA version 1.0.16

In any case, ALSA version 1.0.24 is recommended as any older versions
may cause spurious failures when used in VLC.
parent f55dc228
...@@ -3459,11 +3459,11 @@ AC_ARG_ENABLE(alsa, ...@@ -3459,11 +3459,11 @@ AC_ARG_ENABLE(alsa,
[ --enable-alsa Advanced Linux Sound Architecture (default auto)]) [ --enable-alsa Advanced Linux Sound Architecture (default auto)])
have_alsa="no" have_alsa="no"
AS_IF([test "${enable_alsa}" != "no"], [ AS_IF([test "${enable_alsa}" != "no"], [
PKG_CHECK_MODULES([ALSA], [alsa >= 1.0.0], [ PKG_CHECK_MODULES([ALSA], [alsa >= 1.0.16], [
have_alsa="yes" have_alsa="yes"
], [ ], [
AS_IF([test "x${enable_alsa}" != "x"], [ AS_IF([test "x${enable_alsa}" != "x"], [
AC_MSG_ERROR([alsa-lib not found]) AC_MSG_ERROR([alsa-lib version 1.0.16 or later not found])
]) ])
]) ])
]) ])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment