Commit b8f6df75 authored by David Flynn's avatar David Flynn Committed by Jean-Baptiste Kempf

win32: Fix *printf & require mingw32-runtime version > 3.13

*printf as per MSVCRT is not c99 compliant.  mingw32 provides a set of
replacement functions, but these are buggy in old versions.

Defining __USE_MINGW_ANSI_STDIO causes mingw's stdio to provide a
set of wrappers that use the mingw32 version that gets statically
linked.

Attention needs to be given to contrib too, it is possible for contrib
to expect a c99 *printf and later die.  This patch modifies the conrtib
bootstrap to define the above in CPPFLAGS, however, not all builds
honour CPPFLAGS.

This can be validated by looking for the import from msvcrt:

  $ find vlc-w32/vlc-1.0.0-pre1/ -name '*.dll' -print -exec sh -c \
     'i586-mingw32msvc-nm {} | grep __imp__.*printf' ';'

If all is good, this shouldn't find anything.

This patch *will* break WinCE support.  However, it is semibroken
anyway; better to force it to be fixed completely.
Signed-off-by: default avatarDavid Flynn <davidf@rd.bbc.co.uk>
Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent 6bcbeed3
......@@ -453,6 +453,24 @@ AM_ICONV
VLC_ADD_CFLAGS([libvlc],[${INCICONV}])
VLC_ADD_LIBS([libvlc],[${LTLIBICONV}])
dnl Check for broken versions of mingw-runtime compatability library
if test "${SYS}" = "mingw32"
then
AC_MSG_CHECKING(for broken mingw-runtime)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <_mingw.h>
#if (__MINGW32_MAJOR_VERSION == 3) && (__MINGW32_MINOR_VERSION < 14)
# error Attempting to use mingw-runtime with broken vsnprintf support
#endif
]])],
[AC_MSG_RESULT([Ok])],
[AC_MSG_ERROR([Broken mingw-runtime, need > 3.13])],
])
dnl force use of mingw provided c99 *printf over msvcrt
CPPFLAGS="${CPPFLAGS} -D__USE_MINGW_ANSI_STDIO=1"
CPPFLAGS_save="${CPPFLAGS_save} -D__USE_MINGW_ANSI_STDIO=1"
fi
dnl Check for the need to include the mingwex lib for mingw32
if test "${SYS}" = "mingw32"
then
......
......@@ -26,6 +26,19 @@
#ifndef LIBVLC_FIXUPS_H
# define LIBVLC_FIXUPS_H 1
#ifdef __MINGW32_VERSION
# if __MINGW32_MAJOR_VERSION == 3 && __MINGW32_MINOR_VERSION < 14
# error This mingw-runtime is too old, it has a broken vsnprintf
# endif
/* mingw-runtime provides the whole printf family in a c99 compliant way. */
/* the way to enable this is to define __USE_MINGW_ANSI_STDIO, or something
* such as _ISOC99_SOURCE; the former is done by configure.ac */
/* This isn't done here, since some modules don't include config.h and
* therefore this as the first include file */
#elif defined UNDER_CE
# error Window CE support for *printf needs fixing.
#endif
#ifndef HAVE_STRDUP
# include <string.h>
# include <stdlib.h>
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment