Commit b1228330 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

fontconfig: require version 2.11 (fixes #3314)

parent 810704b6
...@@ -3171,7 +3171,7 @@ if test "${enable_freetype}" != "no"; then ...@@ -3171,7 +3171,7 @@ if test "${enable_freetype}" != "no"; then
dnl fontconfig support dnl fontconfig support
AS_IF([test "${enable_fontconfig}" != "no" -a "${SYS}" != "mingw32" -a "${SYS}" != "darwin"], [ AS_IF([test "${enable_fontconfig}" != "no" -a "${SYS}" != "mingw32" -a "${SYS}" != "darwin"], [
PKG_CHECK_MODULES(FONTCONFIG, [fontconfig], [ PKG_CHECK_MODULES(FONTCONFIG, [fontconfig >= 2.11], [
have_fontconfig="yes" have_fontconfig="yes"
], [ ], [
AC_MSG_WARN([${FONTCONFIG_PKG_ERRORS}. Styles will be disabled in FreeType.]) AC_MSG_WARN([${FONTCONFIG_PKG_ERRORS}. Styles will be disabled in FreeType.])
......
...@@ -4,7 +4,7 @@ FONTCONFIG_VERSION := 2.11.1 ...@@ -4,7 +4,7 @@ FONTCONFIG_VERSION := 2.11.1
FONTCONFIG_URL := https://www.freedesktop.org/software/fontconfig/release/fontconfig-$(FONTCONFIG_VERSION).tar.gz FONTCONFIG_URL := https://www.freedesktop.org/software/fontconfig/release/fontconfig-$(FONTCONFIG_VERSION).tar.gz
PKGS += fontconfig PKGS += fontconfig
ifeq ($(call need_pkg,"fontconfig >= 2.10.92"),) ifeq ($(call need_pkg,"fontconfig >= 2.11"),)
PKGS_FOUND += fontconfig PKGS_FOUND += fontconfig
endif endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment