Commit 8021369f authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont

configure: add check for libidn

Note that versions 1.24 and later of GNU/libidn are dual-licensed under
GPLv2+ and LGPLv3+. As with GnuTLS or Samba client, there are 3 ways
to retain LibVLC binaries under LGPLv2.1+:
 - link against a version of GNU/libidn from last year (or older),
 - do not support IDN at all,
 - use another IDNA back-end (e.g. Windows Vista's Normaliz.dll).
parent 85b21302
......@@ -776,6 +776,17 @@ fi
AM_CONDITIONAL(HAVE_MINIZIP, [ test "${have_minizip}" = "yes" ])
dnl
dnl Domain name i18n support via GNU libidn
dnl
PKG_CHECK_MODULES([IDN], [libidn], [
have_libidn="yes"
AC_DEFINE([HAVE_IDN], 1, [Define to 1 if you have GNU libidn.])
], [
have_libidn="no"
])
dnl Check for dbus
AC_ARG_ENABLE(dbus,
[AS_HELP_STRING([--enable-dbus],
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment