Commit 641707d3 authored by Felix Paul Kühne's avatar Felix Paul Kühne

* added out-of-the-box support for future darwin releases. right now, the...

* added out-of-the-box support for future darwin releases. right now, the following libraries are broken (due to linking issues): cdio, cddb, vcdimager and twolame. additionally, x264 doesn't compile because of a bug in makefile/config.mak.
parent 38490622
......@@ -134,6 +134,10 @@ case $HOST in
;;
esac
if test `uname -r` = "9.0.0d5"; then
echo "HAVE_FUTURE_DARWIN_OS = 1" >> config.mak
fi
echo "BUILD = $BUILD" >> config.mak
echo "HOST = $HOST" >> config.mak
......
......@@ -144,13 +144,23 @@ endif
# ***************************************************************************
ifdef HAVE_DARWIN_OS
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .twolame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager .SDL_image \
.glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder .aclocal \
.libdca .tag .x264 .goom2k4
ifdef HAVE_FUTURE_DARWIN_OS
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .SDL_image \
.glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder \
.libdca .tag .goom2k4 .aclocal
else
all: .autoconf .automake .libtool .intl .pkgcfg .freetype .fribidi \
.a52 .mpeg2 .id3tag .mad .ogg .vorbis .vorbisenc .theora \
.FLAC .speex .shout .faad .faac .lame .twolame .ebml .matroska .ffmpeg \
.dvdcss .dvdnav .dvdread .dvbpsi .live .caca .mod \
.png .gpg-error .gcrypt .gnutls .opendaap .cddb .cdio .vcdimager .SDL_image \
.glib .libidl .gecko .mpcdec .dirac_encoder .dirac_decoder \
.libdca .tag .x264 .goom2k4 .aclocal
endif
# .expat .clinkcc don't work with SDK yet
# .glib .libidl .gecko are required to build the mozilla plugin
# .mozilla will build an entire mozilla. it can be used if we need to create a new .gecko package
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment