Commit 618d4d65 authored by Sam Hocevar's avatar Sam Hocevar

* debian/rules:

    + Replaced $(DEB_BUILD_ARCH) with `dpkg-architecture -qDEB_BUILD_GNU_CPU`
      so that the rules can be called directly.
  * debian/control:
    + Removed leading "a"s from package descriptions.
    + Set policy to 3.5.10.
  * debian/copyright:
    + Removed debian/vlc.copyright.
parent ec654616
......@@ -4,8 +4,8 @@ EXTRA_DIST = \
README.Debian \
changelog \
control \
copyright \
rules \
vlc.copyright \
vlc.dirs \
vlc.docs \
vlc.menu \
......
vlc (0.5.3-4) unstable; urgency=low
* debian/rules:
+ Replaced $(DEB_BUILD_ARCH) with `dpkg-architecture -qDEB_BUILD_GNU_CPU`
so that the rules can be called directly.
* debian/control:
+ Removed leading "a"s from package descriptions.
+ Set policy to 3.5.10.
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Sat, 7 Jun 2003 17:46:36 +0200
vlc (0.5.3-3) unstable; urgency=low
* Built-in modules were linked twice in the mozilla plugin; removed the
......
......@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Samuel Hocevar <sam@zoy.org>
Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0)
Build-Conflicts: libmpeg2-dev, libmpeg2-0-dev, libmpeg2-1-dev, libmpeg2-2-dev, libmpeg2-3-dev
Standards-Version: 3.5.9.0
Standards-Version: 3.5.10
Package: vlc
Section: graphics
......@@ -15,7 +15,7 @@ Suggests: gnome-vlc
Replaces: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
Conflicts: vlc-plugin-dvb (<< 0.5.2-2), vlc-plugin-xosd (<< 0.5.2-2), vlc-plugin-dv (<< 0.5.2-2), vlc-plugin-mad (<< 0.5.2-2), vlc-mad (<< 0.5.0), vlc-plugin-a52 (<< 0.5.2-2), vlc-plugin-ogg (<< 0.5.2-2), vlc-plugin-lirc (<< 0.5.2-2), vlc-lirc (<< 0.5.0), vlc-plugin-aa (<< 0.5.2-2), vlc-aa (<< 0.5.0)
Provides: mp3-decoder
Description: a complete multimedia player
Description: complete multimedia player
This is the VideoLAN project's VLC media player. It plays MPEG, MPEG2,
MPEG4, DivX, mp3, Ogg/Vorbis files, DVDs, VCDs, and multimedia streams
from various network sources.
......@@ -174,7 +174,7 @@ Package: mozilla-plugin-vlc
Architecture: any
Depends: vlc (= ${Source-Version}), ${shlibs:Depends}
Recommends: mozilla-browser
Description: a multimedia plugin for Mozilla based on VLC
Description: multimedia plugin for Mozilla based on VLC
This plugin adds support for MPEG, MPEG2, DVD, DivX, Ogg/Vorbis and many
more formats to your Mozilla browser. The decoding process is done by VLC
and the output window is embedded in a webpage or directly in the browser
......
This package was debianized by Samuel Hocevar <sam@zoy.org> on
This package was debianized by Sam Hocevar <sam@zoy.org> on
Mon, 13 Mar 2000 02:21:45 +0100.
It was taken from the CVS tree. See http://www.videolan.org/cvs.html
......
......@@ -51,7 +51,7 @@ CONFIG_FLAGS += --enable-faad --with-faad-tree=extras/faad
CONFIG_FLAGS += --enable-libmpeg2 --with-libmpeg2-tree=extras/mpeg2dec
# Glide is only for x86
ifeq ($(DEB_BUILD_ARCH),i386)
ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
CONFIG_FLAGS += --enable-glide
CONFIG_FLAGS += --enable-svgalib
else
......@@ -127,7 +127,7 @@ build-stamp:
# Build only VLC, with the non-PIC libs
$(MAKE) vlc
ifneq ($(DEB_BUILD_ARCH),i386)
ifneq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
# Hackety hackety hack
if test ! -d CVS; then \
cd extras/ffmpeg/libavcodec \
......@@ -276,7 +276,7 @@ install: build
ln -s vlc debian/vlc-ggi/usr/share/doc/vlc-ggi
# Package: vlc-plugin-glide
ifeq ($(DEB_BUILD_ARCH),i386)
ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
ln -s vlc debian/vlc-plugin-glide/usr/share/doc/vlc-plugin-glide
mv debian/vlc/usr/lib/vlc/video_output/libglide_plugin.so \
debian/vlc-plugin-glide/usr/lib/vlc/video_output/
......@@ -320,7 +320,7 @@ endif
mv debian/vlc/$(VIDDIR)/kvlc48x48.png debian/kvlc/$(PIXDIR)/kvlc.png
# Package: vlc-plugin-svgalib
ifeq ($(DEB_BUILD_ARCH),i386)
ifeq ($(shell dpkg-architecture -qDEB_BUILD_GNU_CPU),i386)
ln -s vlc debian/vlc-plugin-svgalib/usr/share/doc/vlc-plugin-svgalib
mv debian/vlc/usr/lib/vlc/video_output/libsvgalib_plugin.so \
debian/vlc-plugin-svgalib/usr/lib/vlc/video_output
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment