Commit 46b2ae06 authored by Jean-Baptiste Kempf's avatar Jean-Baptiste Kempf

MacOS: always specify a minimum-sdk

This fixes issues on X.6 and X.7 when compiled with SDK10.5
The configure would fail to see -crt10.6 library and die on poll()
Signed-off-by: Jean-Baptiste Kempf's avatarJean-Baptiste Kempf <jb@videolan.org>
parent 8b9b52a7
......@@ -168,6 +168,9 @@ case "${host_os}" in
AC_ARG_WITH(macosx-version-min,
[AS_HELP_STRING([--with-macosx-version-min=VERSION],
[compile for MacOS X VERSION and above])])
if test "${with_macosx_version_min}" = "" ; then
with_macosx_version_min=10.5
fi
if test "${with_macosx_version_min}" != "" ; then
CPP="${CPP} -mmacosx-version-min=${with_macosx_version_min}"
CC="${CC} -mmacosx-version-min=${with_macosx_version_min}"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment