Commit 33173810 authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont
Browse files

Check for libgnutls

parent dc437b8d
......@@ -1208,6 +1208,15 @@ then
AC_DEFINE(ENABLE_VLM, 1, Define if you want the VideoLAN manager support)
fi
dnl
dnl TLS/SSL
dnl
AC_ARG_ENABLE(tls,
[ --enable-tls TLS/SSL support (default disabled)])
AS_IF([test "${enable_tls}" == "yes"],
AC_DEFINE(ENABLE_TLS, 1, Define if you want the TLS/SSL support))
dnl
dnl Input plugins
dnl
......@@ -3813,6 +3822,45 @@ AM_CONDITIONAL(ENABLE_CORBA, test "$enablecorba" = "true")
AC_ARG_WITH(,[Misc options:])
dnl
dnl GnuTLS-based TLS/SSL support
dnl
AC_ARG_WITH(libgnutls-prefix,
[ --with-libgnutls-prefix=PFX Set prefix where libgnutls is installed],
libgnutls_config_prefix="$withval", libgnutls_config_prefix="")
AS_IF([test x$libgnutls_config_prefix != x],
AS_IF([test x${LIBGNUTLS_CONFIG+set} != xset],
LIBGNUTLS_CONFIG=$libgnutls_config_prefix/bin/libgnutls-config
)
)
if test "x$enable_tls" == "xyes"; then
AC_PATH_PROG(LIBGNUTLS_CONFIG, libgnutls-config, no)
no_libgnutls=""
AC_MSG_CHECKING(for libgnutls - version >= 1.0.0)
AS_IF([test "$LIBGNUTLS_CONFIG" = "no"],
no_libgnutls=yes
,
LIBGNUTLS_CFLAGS=`$LIBGNUTLS_CONFIG $libgnutls_config_args --cflags`
LIBGNUTLS_LIBS=`$LIBGNUTLS_CONFIG $libgnutls_config_args --libs`
libgnutls_config_version=`$LIBGNUTLS_CONFIG $libgnutls_config_args --version`
)
AS_IF([test "x$no_libgnutls" = x],
AC_MSG_RESULT(yes)
VLC_ADD_CFLAGS([vlc], [$LIBGNUTLS_CFLAGS])
VLC_ADD_LDFLAGS([vlc], [$LIBGNUTLS_LIBS])
AC_DEFINE(HAVE_GNUTLS, 1, Define to 1 if you have libgnutls)
,
AC_MSG_RESULT(no)
LIBGNUTLS_CFLAGS=""
LIBGNUTLS_LIBS=""
AC_MSG_ERROR(TLS/SSL support cannot be compiled)
)
fi
dnl
dnl Endianness check, AC_C_BIGENDIAN doesn't work if we are cross-compiling
dnl
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment