Commit 2d8a1a70 authored by Sam Hocevar's avatar Sam Hocevar

* ./HACKING: we can now use automake-1.5 instead of automake-1.6. But now

    we _really_ depend on it.
  * ./bootstrap: we don't use touch to create a file, because it doesn't seem
    to work everywhere.
parent 685f8edc
.* .*
m4 m4
intl intl
ABOUT-NLS
core core
core.* core.*
gmon.out gmon.out
...@@ -13,6 +14,7 @@ config.rpath ...@@ -13,6 +14,7 @@ config.rpath
config.status config.status
config.guess config.guess
config.sub config.sub
autom4te.cache
Makefile Makefile
Makefile.in Makefile.in
Makefile.opts Makefile.opts
......
$Id: HACKING,v 1.3 2002/08/26 20:49:49 sam Exp $ $Id: HACKING,v 1.4 2002/08/27 14:15:24 sam Exp $
Hacking vlc Hacking vlc
=========== ===========
...@@ -6,8 +6,8 @@ Hacking vlc ...@@ -6,8 +6,8 @@ Hacking vlc
You will need the following tools if you plan to use the CVS version of vlc: You will need the following tools if you plan to use the CVS version of vlc:
- autoconf version 2.50 or later - autoconf version 2.50 or later
- automake version 1.6 or later - automake version 1.5 (but 1.6 is recommended)
- gettext version 0.10.4 or later - gettext version 0.10.40 (but 0.11.3 or later is recommended)
After retrieving the CVS tree, you need to run the bootstrap script to After retrieving the CVS tree, you need to run the bootstrap script to
generate all the files needed to build vlc. You can then run configure. generate all the files needed to build vlc. You can then run configure.
......
#! /bin/sh #! /bin/sh
## bootstrap.sh file for vlc, the VideoLAN Client ## bootstrap.sh file for vlc, the VideoLAN Client
## $Id: bootstrap,v 1.6 2002/08/26 23:36:20 sam Exp $ ## $Id: bootstrap,v 1.7 2002/08/27 14:15:24 sam Exp $
## ##
## Authors: Samuel Hocevar <sam@zoy.org> ## Authors: Samuel Hocevar <sam@zoy.org>
...@@ -50,14 +50,15 @@ else ...@@ -50,14 +50,15 @@ else
# do cp ${aclocaldir}/${file} m4/ # do cp ${aclocaldir}/${file} m4/
#done #done
# Yuck! # Yuck!
touch m4/Makefile.am echo > m4/Makefile.am
# Yuck! # Yuck!
echo 'AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])' > m4/gettext.m4 echo 'AC_DEFUN([AM_GNU_GETTEXT_VERSION], [])' > m4/gettext.m4
fi fi
aclocal -I m4 aclocal-1.6 -I m4 || aclocal-1.5 -I m4
autoheader autoheader
automake --foreign --add-missing --copy automake-1.6 --foreign --add-missing --copy \
|| automake-1.5 --foreign --add-missing --copy
autoconf autoconf
# nuahahahahaha !! overwriting Makefile.in with what *I* want! # nuahahahahaha !! overwriting Makefile.in with what *I* want!
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment