Commit 2b737862 authored by hartman's avatar hartman
Browse files

libmpeg2: user_data has been available since 0.3.2

Since we require libmpeg > 0.3.2 there is no need for this check.
parent 462d6d04
......@@ -453,7 +453,6 @@ static picture_t *DecodeBlock( decoder_t *p_dec, block_t **pp_block )
mpeg2_set_buf( p_sys->p_mpeg2dec, buf, p_pic );
mpeg2_stride( p_sys->p_mpeg2dec, p_pic->p[Y_PLANE].i_pitch );
}
#if MPEG2_RELEASE >= MPEG2_VERSION (0, 5, 0)
if( p_sys->p_info->user_data_len > 2 )
{
p_sys->i_cc_pts = i_pts;
......@@ -468,7 +467,6 @@ static picture_t *DecodeBlock( decoder_t *p_dec, block_t **pp_block )
cc_Extract( &p_sys->cc, &p_sys->p_info->user_data[0], p_sys->p_info->user_data_len );
}
#endif
}
break;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment