Commit 4b1c9dcd authored by Rémi Denis-Courmont's avatar Rémi Denis-Courmont

configure: require C++11

Rationale: the adaptive plugin requires C++11; it won´t build on a C++98
compiler or C++11 compiler in C++98 mode.
parent 606776eb
...@@ -79,7 +79,7 @@ dnl Check for compiler properties ...@@ -79,7 +79,7 @@ dnl Check for compiler properties
AC_C_CONST AC_C_CONST
AC_C_INLINE AC_C_INLINE
AC_C_RESTRICT AC_C_RESTRICT
AX_CXX_COMPILE_STDCXX_11(noext, optional) AX_CXX_COMPILE_STDCXX_11(noext, mandatory)
dnl Extend the --help string at the current spot. dnl Extend the --help string at the current spot.
AC_DEFUN([EXTEND_HELP_STRING], [m4_divert_once([HELP_ENABLE], [$1])]) AC_DEFUN([EXTEND_HELP_STRING], [m4_divert_once([HELP_ENABLE], [$1])])
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment