Commit a8770b1a authored by Jean-Baptiste Kempf's avatar Jean-Baptiste Kempf

Configure: disable-lua if correct luac is not found

This is temporary until we have a better solution
parent 98555255
......@@ -1555,7 +1555,8 @@ then
AC_MSG_ERROR([Could not find the LUA byte compiler.])
])
AS_IF([test -d "${CONTRIB_DIR}" -a -f "${CONTRIB_DIR}/lib/liblua.a" -a `echo|${LUAC} -o - -|od -j 8 -N 2 -t x2|head -n 1|tr -s ' '|cut -d' ' -f2` != 0404], [
AC_MSG_ERROR([You need 32-bits luac when using lua from contrib.])
AC_MSG_WARN([You need 32-bits luac when using lua from contrib.])
have_lua=no
])
fi
AM_CONDITIONAL(BUILD_LUA, [test "${have_lua}" = "yes"])
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment