Commit ab9b3042 authored by Jean-Baptiste Kempf's avatar Jean-Baptiste Kempf

FFmpeg update.

parent e9deaa7e
......@@ -1067,8 +1067,7 @@ DISTCLEAN_PKG += amrwb-$(LIBAMR_WB_VERSION).tar.bz2
ifdef SVN
ffmpeg:
$(SVN) co $(FFMPEG_SVN) ffmpeg -r 12920
(cd $@; patch -p0 < ../Patches/ffmpeg-pkg-config.patch)
$(SVN) co $(FFMPEG_SVN) ffmpeg
ifeq ($(HOST),i586-pc-beos)
(cd $@; patch -p0 < ../Patches/ffmpeg-svn-beos.patch)
endif
......@@ -1090,7 +1089,6 @@ ifdef HAVE_UCLIBC
patch -p0 < Patches/ffmpeg-svn-internal-define.patch
patch -p0 < Patches/ffmpeg-svn-libavformat.patch
endif
(cd $@; patch -p0 < ../Patches/ffmpeg-svn-configure.patch )
else
ffmpeg-$(FFMPEG_VERSION).tar.gz:
echo "ffmpeg snapshot is too old, you MUST use subversion !"
......
Index: configure
===================================================================
--- configure (révision 13435)
+++ configure (copie de travail)
@@ -2169,11 +2169,13 @@
version=$3
libs=$4
requires=$5
+libdir_pc=`echo $libdir|sed s'|$(PREFIX)|${prefix}|'`
+incdir_pc=`echo $incdir|sed 's|$(PREFIX)|${prefix}|'`
cat <<EOF >$name.pc
prefix=$prefix
exec_prefix=\${prefix}
-libdir=$libdir
-includedir=$incdir
+libdir=$libdir_pc
+includedir=$incdir_pc
Name: $name
Description: $comment
Index: configure
===================================================================
--- configure (revision 12501)
+++ configure (working copy)
@@ -2201,8 +2201,8 @@
fi
if enabled swscale; then
- pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" -lswscale "libavutil = $LIBAVUTIL_VERSION"
- pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "libavutil = $LIBAVUTIL_VERSION"
+ pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "-lswscale -lm" "libavutil = $LIBAVUTIL_VERSION"
+ pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "-lm" "libavutil = $LIBAVUTIL_VERSION"
else
pkgconfig_generate libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "$pkg_requires libavcodec = $LIBAVCODEC_VERSION"
pkgconfig_generate_uninstalled libswscale "FFmpeg image rescaling library" "$LIBSWSCALE_VERSION" "" "$pkg_requires libavcodec = $LIBAVCODEC_VERSION"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment