Commit 8114a97f authored by Felix Paul Kühne's avatar Felix Paul Kühne

contribs: enforce usage of gcc-4.2 instead of llvm-gcc-4.2 for libx264 to...

contribs: enforce usage of gcc-4.2 instead of llvm-gcc-4.2 for libx264 to ensure proper linking on both PPC and x86 based Macs

Binary packages will need an update here.
parent efe23f26
......@@ -156,6 +156,10 @@ endif
ifdef HAVE_DARWIN_OS_ON_INTEL
FFMPEG_CFLAGS += -DHAVE_LRINTF
endif
X264CC+= CC="/Developer/usr/bin/gcc-4.2"
X264CC+= CXX="/Developer/usr/bin/g++-4.2"
else
X264CC+= $(HOSTCC)
endif
ifdef HAVE_AMR
......@@ -1435,10 +1439,10 @@ ifdef HAVE_WIN32
else
ifdef HAVE_DARWIN_OS_ON_INTEL
.x264: x264 .yasm
(cd $<; $(HOSTCC) ./configure $(X264CONF) --prefix="$(PREFIX)" && make && make install)
(cd $<; $(X264CC) ./configure $(X264CONF) --prefix="$(PREFIX)" && make && make install)
else
.x264: x264
(cd $<; $(HOSTCC) ./configure $(X264CONF) --prefix="$(PREFIX)" && make && make install)
(cd $<; $(X264CC) ./configure $(X264CONF) --prefix="$(PREFIX)" && make && make install)
endif
endif
touch $@
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment