Commit 8b599c45 authored by Hugo Beauzée-Luyssen's avatar Hugo Beauzée-Luyssen

extras/tools: Add nasm

It's required by newer x264
parent 6a23f1d6
......@@ -14,3 +14,4 @@ dbbb0bb348fac54612d29182c09c88bda7096dea03bd94f03c580c24146e65a06db12808c6a1a9ad
e80ace766e145f6486e76da1a5a9819221b7f406745a02529b4ad220ef7f51ddd67f23d0d8b187bffc9725d9f9742ae5f3a0bb23ee5b2a61153332fb3e286b77 yasm-1.2.0.tar.gz
bbdc23e7772e49da1c7c47e66d4e4efbfbfe9b21dbc59bf3ad9a6e573eecac6c9f52c7f11a64be9897e8deb99ef7ba015164aa8232aa391b901dd7db03632412 bison-3.0.4.tar.xz
e9785f3d620a204b7d20222888917dc065c2036cae28667065bf7862dfa1b25235095a12fd04efdbd09bfd17d3452e6b9ef953a8c1137862ff671c97132a082e flex-2.6.4.tar.gz
611e573756e3e936ce16b456df9583eb9acae51a0fbd28212444ddc0c1c5ec21e893d7a666bd77ef53423024939291a31dcf86d129126fa707b729d80b24184d nasm-2.13.03.tar.gz
......@@ -85,6 +85,7 @@ check ant
check xz
check bison 3.0.0
check flex
check nasm 2.13.01
[ -n "$NEEDED" ] && mkdir -p build/ && echo "To-be-built packages: `echo $NEEDED | sed 's/\.//g'`"
......
......@@ -6,6 +6,9 @@ VIDEOLAN=http://downloads.videolan.org/pub/contrib
YASM_VERSION=1.2.0
YASM_URL=http://www.tortall.net/projects/yasm/releases/yasm-$(YASM_VERSION).tar.gz
NASM_VERSION=2.13.03
NASM_URL=http://www.nasm.us/pub/nasm/releasebuilds/$(NASM_VERSION)/nasm-$(NASM_VERSION).tar.gz
CMAKE_VERSION=3.8.2
CMAKE_URL=http://www.cmake.org/files/v3.8/cmake-$(CMAKE_VERSION).tar.gz
......
......@@ -62,6 +62,21 @@ CLEAN_FILE += .yasm
CLEAN_PKG += yasm
DISTCLEAN_PKG += yasm-$(YASM_VERSION).tar.gz
nasm-$(NASM_VERSION).tar.gz:
$(call download_pkg,$(NASM_URL),nasm)
nasm: nasm-$(NASM_VERSION).tar.gz
$(UNPACK)
$(MOVE)
.nasm: nasm
(cd $<; ./configure --prefix=$(PREFIX) && $(MAKE) && $(MAKE) install)
touch $@
CLEAN_FILE += .nasm
CLEAN_PKG += nasm
DISTCLEAN_PKG += nasm-$(NASM_VERSION).tar.gz
# cmake
cmake-$(CMAKE_VERSION).tar.gz:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment