Commit 6839a212 authored by Hugo Beauzée-Luyssen's avatar Hugo Beauzée-Luyssen

tools: bootstrap: Fix nasm version check

parent 8dc86858
......@@ -63,6 +63,19 @@ then
fi
}
check_nasm() {
if ! nasm -v >/dev/null 2>&1
then
echo "nasm not found"
NEEDED="$NEEDED .nasm"
else
# found, need to check version ?
[ -z "$1" ] && return # no
gotver=`nasm -v | cut -d ' ' -f 3`
check_version nasm $gotver $1
fi
}
check() {
if ! $1 --version >/dev/null 2>&1 && ! $1 -version >/dev/null 2>&1
then
......@@ -91,7 +104,7 @@ check ant
check xz
check bison 3.0.0
check flex
check nasm 2.13.01
check_nasm 2.13.01
[ -n "$NEEDED" ] && mkdir -p build/ && echo "To-be-built packages: `echo $NEEDED | sed 's/\.//g'`"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment