Commit 1162a9ff authored by Martin Storsjö's avatar Martin Storsjö

Qt: Require Qt 5.9.0 as minimum version

Qt 5.9 is the current LTS branch, first released in May 2017.
parent 3ad15214
......@@ -3692,7 +3692,7 @@ AC_ARG_ENABLE(qt, [
])
have_qt5_x11="no"
AS_IF([test "${enable_qt}" != "no"], [
PKG_CHECK_MODULES([QT], [Qt5Core >= 5.5.0 Qt5Widgets Qt5Gui Qt5Svg], [
PKG_CHECK_MODULES([QT], [Qt5Core >= 5.9.0 Qt5Widgets Qt5Gui Qt5Svg], [
PKG_CHECK_MODULES([QT5_X11], [Qt5X11Extras], [
have_qt5_x11="yes"
],[
......
......@@ -43,8 +43,8 @@
#include <QString>
#include <QUrl>
#if ( QT_VERSION < 0x050500 )
# error Update your Qt version to at least 5.5.0
#if ( QT_VERSION < 0x050900 )
# error Update your Qt version to at least 5.9.0
#endif
#define HAS_QT56 ( QT_VERSION >= 0x050600 )
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment