Commit 09496f19 authored by Sam Hocevar's avatar Sam Hocevar

* Makefile.am: "make dist-woody" builds a tarball suitable for a Debian

    woody package build.
  * bootstrap:
    + Remove config.h.in and config.h before running autoheader.
    + Added "set -e" for better error tracking.
    + Call autoheader and automake after autoconf so that the first build does
      not need to call autoheader.
  * debian/woody-buildpackage:
    + Removed that script and put the code in toolbox.
  * debian/control:
    + Added a build-dependency on libmatroska-dev.
  * debian/rules:
    + Activated Matroska support.
    + Re-enabled dh_installchangelogs.
parent 1cd9bbce
......@@ -420,6 +420,24 @@ share/vlc_win32_rc.$(OBJEXT): share/vlc_win32_rc.rc
$(WINDRES) --include-dir $(srcdir)/share -i $< -o $@
endif
###############################################################################
# Building specific source packages
###############################################################################
dist-woody: distdir
$(remove_distdir_woody)
mv $(distdir) $(PACKAGE)-woody-$(VERSION)
$(srcdir)/toolbox --make-woody $(PACKAGE)-woody-$(VERSION)
$(AMTAR) chof - $(PACKAGE)-woody-$(VERSION) \
| GZIP=$(GZIP_ENV) gzip -c >$(PACKAGE)-woody-$(VERSION).tar.gz
$(remove_distdir_woody)
remove_distdir_woody = \
{ test ! -d $(PACKAGE)-woody-$(VERSION) \
|| { find $(PACKAGE)-woody-$(VERSION) -type d ! -perm -200 \
-exec chmod u+w {} ';' \
&& rm -fr $(PACKAGE)-woody-$(VERSION); }; }
###############################################################################
# Building architecture-specific binary packages
###############################################################################
......
#! /bin/sh
## bootstrap file for the VLC media player
## $Id: bootstrap,v 1.64 2003/07/04 14:56:51 sam Exp $
## $Id: bootstrap,v 1.65 2003/07/05 14:47:53 sam Exp $
##
## Authors: Sam Hocevar <sam@zoy.org>
......@@ -20,16 +20,14 @@ export LANG
CYGWIN=binmode
export CYGWIN
set -e
##
## Naively assume our system doesn't suck. Unfortunately it seldom doesn't.
##
AUTOMAKESUCKS=no
INSTALLSUCKS=no
##
## Check that our tools don't suck
##
##
## Generate the modules makefile, by parsing modules/**/Modules.am
##
......@@ -252,7 +250,7 @@ echo "done."
set -x
# remove autotools cruft
rm -f aclocal.m4 configure configure.ac.in config.log Modules.am
rm -f aclocal.m4 configure configure.ac.in config.log Modules.am config.h config.h.in
# remove old autotools extra cruft
rm -f config.guess config.sub missing mkinstalldirs compile depcomp install-sh
# remove new autotools extra cruft
......@@ -269,7 +267,7 @@ if gettextize --version >/dev/null 2>&1; then
if expr `gettextize --version | sed -e '1s/[^0-9]*//' -e q` \
'>=' 0.11.5 >/dev/null 2>&1; then
# We have gettext, and a recent version! Everything is cool.
autopoint || exit 1
autopoint
GETTEXT=yes
else
# User's gettext is too old. try to continue anyway.
......@@ -349,13 +347,11 @@ fi
rm -f vlc-config.in && printf "" > vlc-config.in
# Do the rest
aclocal${amvers} -I m4 || exit 1
autoheader || exit 1
aclocal${amvers} -I m4
autoconf
autoheader
automake${amvers} --add-missing --copy
autoconf || exit 1
##
## files which need to be regenerated
##
......@@ -364,19 +360,15 @@ rm -f src/misc/modules_builtin.h src/misc/modules_plugin.h
rm -f include/vlc_symbols.h
rm -f mozilla/vlcintf.h
##
## Shut up
##
# Shut up
set +x
##
## Tell the user about gettext, pkg-config and sed
##
case "${GETTEXT}" in
yes)
;;
no)
cat << EOF
yes) ;;
no) cat << EOF
===========================================================
IMPORTANT NOTE: you do not have gettext installed on your
......@@ -384,8 +376,7 @@ system. The vlc build will work, but you will not have
internationalization support. We suggest installing gettext.
EOF
;;
old)
cat << EOF
old) cat << EOF
==========================================================
NOTE: you have an old version of gettext installed on your
......@@ -397,10 +388,8 @@ EOF
esac
case "$PKGCONFIG" in
yes)
;;
no)
cat << EOF
yes) ;;
no) cat << EOF
==============================================================
NOTE: you do not have the "pkg-config" utility on your system;
......@@ -411,10 +400,8 @@ EOF
esac
case "$AUTOMAKESUCKS" in
no)
;;
yes)
cat << EOF
no) ;;
yes) cat << EOF
=============================================================
IMPORTANT NOTE: your version of automake has a bug which will
......@@ -426,10 +413,8 @@ EOF
esac
case "$INSTALLSUCKS" in
no)
;;
yes)
cat << EOF
no) ;;
yes) cat << EOF
=============================================================
IMPORTANT NOTE: your version of automake has a bug which will
......
......@@ -28,7 +28,6 @@ EXTRA_DIST = \
vlc-plugin-glide.dirs \
vlc-plugin-sdl.dirs \
vlc-plugin-svgalib.dirs \
woody-buildpackage \
wxvlc.dirs \
wxvlc.menu \
$(NULL)
vlc (0.6.0+cvs-20030704-1) unstable; urgency=low
vlc (0.6.0+cvs-20030705-1) unstable; urgency=low
* New CVS snapshot.
+ Includes previous Debian fixes.
+ Errors in plugins now properly trigger build abort so that no build
failures are missed. Thanks to LaMont Jones for pointing out the problem.
* debian/rules:
+ Enabled Matroska support.
+ Only build builtins in the first compile pass so that we don't mix PIC
and non-PIC code (Closes: #199968). Phew, I hope I got it right this
time.
......@@ -12,7 +13,7 @@ vlc (0.6.0+cvs-20030704-1) unstable; urgency=low
+ Re-applied the Alpha build fix from 0.6.0+cvs-20030627-2 that had
disappeared in 0.6.0+cvs-20030703-1.
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Thu, 3 Jul 2003 11:25:57 +0200
-- Sam Hocevar (Debian packages) <sam+deb@zoy.org> Sat, 5 Jul 2003 01:09:11 +0200
vlc (0.6.0+cvs-20030703-1) unstable; urgency=low
......
......@@ -2,7 +2,7 @@ Source: vlc
Section: graphics
Priority: optional
Maintainer: Sam Hocevar (Debian packages) <sam+deb@zoy.org>
Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0), libimlib2-dev
Build-Depends: debhelper (>=3.0), gettext, fortune-mod, xlibs-dev, xlibs-pic, libgnome-dev, libggi2-dev, libglide2-dev [i386], libesd0-dev, libsdl1.2-dev (>=1.2.2-3.1), libqt3-mt-dev, libqt3-compat-headers, libasound2-dev (>=0.9.0beta10a), libarts1-dev, libmad0-dev, liblircclient-dev, liba52-0.7.4-dev, aalib1-dev, libdvbpsi1-dev, mozilla-dev, libidl0, libglib2.0-0, kdelibs4-dev, dvb-dev, libdv2-dev, libxosd-dev, svgalibg1-dev (>=1.4.0) [i386], libogg-dev, libvorbis-dev, libwxgtk2.4-dev, libdvdplay0-dev (>=1.0.1-2), libdvdread3-dev, libslp-dev, libflac-dev (>=1.1.0), libimlib2-dev, libmatroska-dev
Build-Conflicts: libmpeg2-dev, libmpeg2-0-dev, libmpeg2-1-dev, libmpeg2-2-dev, libmpeg2-3-dev
Standards-Version: 3.5.10
......
......@@ -44,7 +44,7 @@ CONFIG_FLAGS += \
--enable-skins \
--disable-basic-skins \
--disable-freetype \
--disable-mkv \
--enable-mkv \
--enable-v4l \
$(NULL)
......@@ -366,10 +366,8 @@ binary-arch: build install
dh_installmime -s
dh_installman doc/vlc.1 -p vlc
dh_installman doc/vlc-config.1 -p libvlc0-dev
# dh_installchangelogs ChangeLog -p vlc
cp ChangeLog debian/vlc/usr/share/doc/vlc/changelog
for x in doc/ChangeLog-* ; do cp "doc/ChangeLog-$${x#*-}" "debian/vlc/usr/share/doc/vlc/changelog-$${x#*-}" ; done
cp debian/changelog debian/vlc/usr/share/doc/vlc/changelog.Debian
dh_installchangelogs ChangeLog -p vlc
for x in doc/ChangeLog-* ; do cp "doc/ChangeLog-$${x#*-}" "debian/vlc/usr/share/doc/vlc/changelog$${x#*-}" ; done
dh_link -s
dh_strip -s
dh_compress -s
......
#! /bin/sh
# $Id: woody-buildpackage,v 1.15 2003/07/04 14:56:51 sam Exp $
# Build VLC on a Debian woody system
set -x
set -e
test -d debian
# changelog: replace (1.2.3-4) with (1.2.3-0woody.4)
sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc (\1-0woody.\2)/' \
-e 's/ unstable; / stable; /' \
< debian/changelog > debian/changelog.woody
# control: replace liba52-*-dev with a52dec-dev (>=0.7.3)
# libdv*-dev with libdv-dev
# kdelibs4-dev with kdelibs-dev
# libqt3-mt-dev libqt3-compat-headers with libqt-dev
# libarts1-dev with libarts-dev
# libdvdread3-dev with libdvdread2-dev
# libdvdplay0-dev (>=1.0.1-2) with libdvdplay0-dev
# remove libwxgtk2.4-dev
# libflac-dev
# libidl0 (workaround for mozilla-dev's bad deps)
# libglib2.0-0 (workaround for mozilla-dev's bad deps)
# change Section: gnome with Section: graphics
# Section: kde with Section: kde
# Section: libdevel with Section: devel
sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
-e 's/libdv[0-9]*-dev/libdv-dev/' \
-e 's/kdelibs[0-9]*-dev/kdelibs-dev/' \
-e 's/libqt[0-9]*-mt-dev/libqt-dev/' \
-e 's/, libqt[0-9]*-compat-headers[^,]*//' \
-e 's/libarts[0-9]*-dev/libarts-dev/' \
-e 's/libdvdread[0-9]*-dev/libdvdread2-dev/' \
-e 's/, libdvdplay0-dev[^,]*/, libdvdplay0-dev/' \
-e 's/, libwx[^,]*//' \
-e '/Package: wxvlc/,/^ *$/d' \
-e 's/, libflac-dev[^,]*//' \
-e 's/, libidl0[^,]*//' \
-e 's/, libglib2.0-0[^,]*//' \
-e 's/Section: gnome/Section: graphics/' \
-e 's/Section: kde/Section: graphics/' \
-e 's/Section: libdevel/Section: devel/' \
< debian/control > debian/control.woody
# rules: remove wxwindows stuff
# change changelog path
sed -e '/# Package: wxvlc/,/^ *$/d' \
-e 's,^ARCH_EXCLUDE =,& -Nwxvlc,' \
-e 's,--enable-wxwindows,--disable-wxwindows,' \
-e 's,--enable-skins,--disable-skins,' \
-e 's,--enable-flac,--disable-flac,' \
-e 's, debian/changelog , debian/changelog.woody ,' \
-e 's,dh_gencontrol[^#]*,& -- -ldebian/changelog.woody,' \
< debian/rules > debian/rules.woody
chmod a+x debian/rules.woody
# Environment variables - taken from dpkg-buildpackage
curd="`pwd`"
dirn="`basename \"$curd\"`"
package="`dpkg-parsechangelog -ldebian/changelog.woody | sed -n 's/^Source: //p'`"
version="`dpkg-parsechangelog -ldebian/changelog.woody | sed -n 's/^Version: //p'`"
maintainer="`dpkg-parsechangelog -ldebian/changelog.woody | sed -n 's/^Maintainer: //p'`"
eval `dpkg-architecture -a -t -s -f`
arch="`dpkg-architecture -a -t -qDEB_HOST_ARCH`"
sversion=`echo "$version" | perl -pe 's/^\d+://'`
pv="${package}_${sversion}"
pva="${package}_${sversion}_${arch}"
chg=../"$pva.changes"
# Do the real work
dpkg-checkbuilddeps -B debian/control.woody || exit 1
fakeroot debian/rules.woody clean
#cd ..; dpkg-source -l"$dirn"/debian/changelog.woody -b "$dirn"; cd "$dirn"
debian/rules.woody build
fakeroot debian/rules.woody binary
dpkg-genchanges -ldebian/changelog.woody -cdebian/control.woody >"$chg"
# Clean up
rm -f debian/rules.woody debian/control.woody debian/changelog.woody
#! /bin/sh
## toolbox for the VLC media player
## $Id: toolbox,v 1.37 2003/07/02 20:01:51 gbazin Exp $
## $Id: toolbox,v 1.38 2003/07/05 14:47:53 sam Exp $
##
## Authors: Samuel Hocevar <sam@zoy.org>
......@@ -28,6 +28,7 @@ recognized flags are:
--update-flexml generate and fix flexml and flex code
--changelog update the CVS changelog
--distclean "make distclean"
--make-woody <dir> change distdir <dir> to a woody distdir
EOF
exit 1
}
......@@ -77,6 +78,9 @@ case "$1" in
--distclean)
action=distclean
;;
--make-woody)
action=woody
;;
--help)
help
;;
......@@ -541,3 +545,64 @@ then
# FIXME: a lot of Makefiles are still there
fi
if test "${action}" = "woody"
then
set -ex
test -d "$1"
# changelog: replace (1.2.3-4) with (1.2.3-0woody.4)
sed -e 's/^vlc (\([^)]*\)-\([^-)]*\))/vlc-woody (\1-0woody.\2)/' \
-e 's/ unstable; / stable; /' \
< "$1/debian/changelog" > "$1/debian/changelog.woody"
mv "$1/debian/changelog.woody" "$1/debian/changelog"
# control: replace liba52-*-dev with a52dec-dev (>=0.7.3)
# libdv*-dev with libdv-dev
# kdelibs4-dev with kdelibs-dev
# libqt3-mt-dev libqt3-compat-headers with libqt-dev
# libarts1-dev with libarts-dev
# libdvdread3-dev with libdvdread2-dev
# libdvdplay0-dev (>=1.0.1-2) with libdvdplay0-dev
# remove libwxgtk2.4-dev
# libflac-dev
# libidl0 (workaround for mozilla-dev's bad deps)
# libglib2.0-0 (workaround for mozilla-dev's bad deps)
# libmatroska-dev
# change Source: vlc with Source: vlc-woody
# Section: gnome with Section: graphics
# Section: kde with Section: kde
# Section: libdevel with Section: devel
sed -e 's/liba52-[^-]*-dev/a52dec-dev (>=0.7.3)/' \
-e 's/libdv[0-9]*-dev/libdv-dev/' \
-e 's/kdelibs[0-9]*-dev/kdelibs-dev/' \
-e 's/libqt[0-9]*-mt-dev/libqt-dev/' \
-e 's/, libqt[0-9]*-compat-headers[^,]*//' \
-e 's/libarts[0-9]*-dev/libarts-dev/' \
-e 's/libdvdread[0-9]*-dev/libdvdread2-dev/' \
-e 's/, libdvdplay0-dev[^,]*/, libdvdplay0-dev/' \
-e 's/, libwx[^,]*//' \
-e '/Package: wxvlc/,/^ *$/d' \
-e 's/, libflac-dev[^,]*//' \
-e 's/, libidl0[^,]*//' \
-e 's/, libglib2.0-0[^,]*//' \
-e 's/, libmatroska-dev[^,]*//' \
-e 's/Source: vlc/Source: vlc-woody/' \
-e 's/Section: gnome/Section: graphics/' \
-e 's/Section: kde/Section: graphics/' \
-e 's/Section: libdevel/Section: devel/' \
< "$1/debian/control" > "$1/debian/control.woody"
mv "$1/debian/control.woody" "$1/debian/control"
# rules: remove wxwindows and skins stuff
# remove flac support
# remove matroska support
sed -e '/# Package: wxvlc/,/^ *$/d' \
-e 's,--enable-wxwindows,--disable-wxwindows,' \
-e 's,--enable-skins,--disable-skins,' \
-e 's,--enable-flac,--disable-flac,' \
-e 's,--enable-mkv,--disable-mkv,' \
< "$1/debian/rules" > "$1/debian/rules.woody"
mv "$1/debian/rules.woody" "$1/debian/rules"
chmod 0755 "$1/debian/rules"
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment