Commit b82dbcb9 authored by Geoffrey Métais's avatar Geoffrey Métais

Upgrade kotlinx to v0.26

parent 87420e40
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
buildscript { buildscript {
ext.android_plugin_version = '3.1.4' ext.android_plugin_version = '3.1.4'
ext.kotlin_version = '1.2.61' ext.kotlin_version = '1.2.61'
ext.kotlinx_version = '0.25.3' ext.kotlinx_version = '0.26.0'
repositories { repositories {
flatDir dirs: "gradle/plugins" flatDir dirs: "gradle/plugins"
google() google()
......
...@@ -27,14 +27,11 @@ import android.os.Handler ...@@ -27,14 +27,11 @@ import android.os.Handler
import android.os.HandlerThread import android.os.HandlerThread
import android.os.Process import android.os.Process
import android.support.v4.util.SimpleArrayMap import android.support.v4.util.SimpleArrayMap
import kotlinx.coroutines.experimental.IO import kotlinx.coroutines.experimental.*
import kotlinx.coroutines.experimental.Job
import kotlinx.coroutines.experimental.android.HandlerContext import kotlinx.coroutines.experimental.android.HandlerContext
import kotlinx.coroutines.experimental.android.UI import kotlinx.coroutines.experimental.android.UI
import kotlinx.coroutines.experimental.channels.Channel import kotlinx.coroutines.experimental.channels.Channel
import kotlinx.coroutines.experimental.channels.mapTo import kotlinx.coroutines.experimental.channels.mapTo
import kotlinx.coroutines.experimental.launch
import kotlinx.coroutines.experimental.withContext
import org.videolan.libvlc.Media import org.videolan.libvlc.Media
import org.videolan.libvlc.util.MediaBrowser import org.videolan.libvlc.util.MediaBrowser
import org.videolan.libvlc.util.MediaBrowser.EventListener import org.videolan.libvlc.util.MediaBrowser.EventListener
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment