Commit ff0dbdd4 authored by Geoffrey Métais's avatar Geoffrey Métais

gradle upgrade + global vars

- Global variables for compileSdkVersion and buildToolsVersion, set only once now.
- upgrade to gradle 0.14.2 wich is currently recommended
- Better Wheelview project declaration
- switch from runProguard to minifyEnabled, runProguard will soon be obsolete
- Ignore translations errors with lint
parent 18194319
......@@ -4,7 +4,7 @@ buildscript {
jcenter()
}
dependencies {
classpath 'com.android.tools.build:gradle:0.13.+'
classpath 'com.android.tools.build:gradle:0.14.2'
}
}
......@@ -13,3 +13,8 @@ allprojects {
jcenter()
}
}
ext {
buildToolsVersion = "21.0.2"
compileSdkVersion = 21
}
\ No newline at end of file
apply plugin: 'com.android.library'
android {
compileSdkVersion 21
buildToolsVersion "21.0.2"
compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
sourceSets {
main {
......@@ -24,7 +24,7 @@ android {
buildTypes {
release {
runProguard false
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
......
apply plugin: 'com.android.library'
android {
compileSdkVersion 21
buildToolsVersion "21.0.2"
compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
sourceSets {
main {
......@@ -26,7 +26,7 @@ android {
buildTypes {
release {
runProguard false
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
......
include ':java-libs/WheelView'
include ':WheelView'
include ':libvlc'
include ':vlc-android'
project(':WheelView').projectDir = new File('java-libs/WheelView')
\ No newline at end of file
......@@ -37,11 +37,12 @@ task buildRelease(type:Exec) {
}
android {
compileSdkVersion 21
buildToolsVersion "21.0.2"
compileSdkVersion rootProject.ext.compileSdkVersion
buildToolsVersion rootProject.ext.buildToolsVersion
lintOptions {
abortOnError false
disable 'MissingTranslation', 'ExtraTranslation'
}
defaultConfig {
......@@ -120,7 +121,7 @@ android {
}
dependencies {
compile project(':java-libs/WheelView')
compile project(':WheelView')
compile project(':libvlc')
compile 'com.android.support:appcompat-v7:21.0.0'
compile 'com.android.support:cardview-v7:21.0.0'
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment